1

Тема: Как настроить переадресацию на домен БЕЗ «www»?

Добрый день!
Недавно начал использовать My-Engine CMS, очень нравиться, но наткнулся на проблему.
Сайт открывается и с www и без www, а это нехорошо для SEO.
Стандартное решение как это не помогло, напишите пожалуйста как исправить.

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.site.ru$ [NC]
RewriteRule ^(.*)$ http://site.ru/$1 [R=301,L]

2

Re: Как настроить переадресацию на домен БЕЗ «www»?

Обратитесь с хостеру, т.к. это скорее всего связано с настройками сервера, а не проблема движка.

Это стандартное правило редиректа отлично работает, не раз проверено и используется, проверьте

https://www.sam-sebe-web-master.3shaga.ru

Поэтому спросите в техподдержке вашего хостинга, почему в этом случае редирект не работает.

3

Re: Как настроить переадресацию на домен БЕЗ «www»?

Думаю, что проблема в файле .htaccess. Я использую для этого движка вот такой файл

# Кодировка сервера
AddDefaultCharset UTF-8

RewriteEngine On
RewriteBase /

# Редирект с www на без www
Options +FollowSymLinks
RewriteCond %{HTTP_HOST} ^www.example\.com$ [NC]
RewriteRule ^(.*)$ http://example.com/$1 [R=301,L]

# Начальный файл
DirectoryIndex index.php

# Ссылки 
Options -Indexes
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/?$ /index.php [L]

# Запрет прямого доступа к системным файлам
<Files "*.dat"> 
deny from all
</Files>
<Files .htaccess>
order allow,deny
deny from all
</Files>

# Страницы ошибок
#-Нет права доступа
ErrorDocument 401 /pages/401.html
#-Запрещено
ErrorDocument 403 /pages/403.html
#-Не найдено
ErrorDocument 404 /pages/404.html
#-Внутренняя ошибка сервера
ErrorDocument 500 /pages/500.html

С этим файлом движок работает стабильно, а вот если в штатный файл просто вставить стандартный редирект с www на без www, то у меня как-то на одном из хостингов тоже появлялась ошибка на внутренних страницах, не такая как у вас, но тоже 404. Эта конфигурация файла htaccess была подобрана экспериментально, после чего ошибка исчезла.

4

Re: Как настроить переадресацию на домен БЕЗ «www»?

Спасибо! Помогло!